読者です 読者をやめる 読者になる 読者になる

Rails実行時にlibgmp関連のエラーが発生した際の対処

Rails

Railsコマンド実行時に以下のようなエラーが発生しました。

$ rails s
/Users/kaoru/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/activesupport-4.1.1/lib/active_support/dependencies.rb:247:in `require': dlopen(/Users/kaoru/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/extensions/x86_64-darwin-13/2.1.0-static/bcrypt-3.1.7/bcrypt_ext.bundle, 9): Library not loaded: /usr/local/lib/libgmp.10.dylib (LoadError)

libgmpがロードできていないということで、以下のコマンドを実行して解決することができました。

$ brew link gmp

参考:hyperlink - brew install gfortran Error: You must `brew link gmp' before gfortran can be installed - Stack Overflow